Saturday, June 17, 2017

Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security

Hallo bro... selamat membaca semoga betah dan artikel ini bermanfaat untuk anda dan saya :)

Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security


DHCP Rogue adalah sebuah server DHCP ilegal yang berada dalam suatu jaringan. DHCP Rogue akan memberikan pengalamatan IP pada client dengan network yang sama tapi berbeda Gateway, biasanya DHCP Rogue di gunakan untuk keperluan penyadapan ( sniffing ). sebelum lebih dalam lagi yuk kita lihat proses DHCP dalam sebuah jaringan dan port berapa yang di gunakan saat proses DHCP berjalan di dalam jaringan.

Proses DHCP Pada Sebuah Jaringan


Dynamic Host Configuration Protocol atau di singkat menjadi DHCP adalah sebuah protokol yang di manfaatkan untuk mendistribusi IP Address ke setiap perangkat client di dalam suatu jaringan secara dinamis. 


Di MikroTik juga di lengkapi fungsi untuk DHCP Sever maupun DHCP Client.

Pada dasarnya proses DHCP sendiri menggunakan protokol transport User Datagram Protocl atau UDP dan menggunakan port 67 untuk di Server dan port 68 untuk di Client. Apabila digambarkan menggunakan diagram proses kerja DHCP seperti berikut ini :

Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security
Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security
Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security
Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security


Dengan memahami proses cara kerja dari DHCP (Dynamic Host Configuration Protocol) pada gambar di atas kita dapat melakukan filtering trafiknya guna menghindar/mencegah adanya DHCP server dari perngakat yang ilegal, yang dapat mengganggu kelancaran jaringan dalam satu jaringan. Pada contoh case saat ini kita akan melakukan filter adalah trafik DHCP Discovery dari client. 


Kasus DHCP ROUGUE [contoh]

Pada Sample kasus ini ada sebuah topologi jaringan yang mana dalam satu network /subnet/segment IP memiliki sebuah DHCP Server yang aktif dan legal. Secara sengaja/tidak adalah DHCP Server lain aktif ilegal, sehingga membuat kemungkinan Client akan mendapatkan IP Address dari DHCP Server ilegal [Rogue] ini. Mengakibatnya koneksi jaringan client menjadi tidak lancar dan terganggu, membuat client/user tidak bisa melakukan/mendapat akses menuju ke internet di sebabkan memperoleh informasi IP yang salah/tidak sesuai. Di contoh kasus ini, kita akan melakukan bloking/tutup traffic DHCP Discover dari Client yang mengarah selain ke DHCP Server aslinya. 

Simaklah gambar di bawah ini untuk memperjelas dari keterangan di atas .

Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security
Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security

Berdasarkan topologi diatas untuk melakukan filtering trafik kita memanfaatkan sebuah Router MikroTik menggunakan mode bridge. Dari mode bridge kita bisa menggunakan fitur dari bridge filter untuk dapat menghandle/mengelolah komunikasi layer 2 yang melalui MikroTik dengan mode bridge itu.

Anggaplah dalam kasus ini sesuai topologi tersebut, DHCP Server yang asli konkesi pada port di ether1 MikroTik Bridge kemudia DHCP Rogue dan perangkat client/user terkonkesi pada port yang lain. Dengan keadaan kasus seperti ini kita bisa dapat membuat rule untuk memberi ijin (ACCEPT) trafik DHCP Discover yang melewati interface ether1 dan melakukan blocking trafik (DROP) di port ethernet yang lain yang tidak legal/Ilegal.

Pengaturan filtering ini akan kita fokuskan di MikroTik mode Bridge yaitu dengan cara yang terdapat pada menu Bridge --> Filters --> klik Add [+]. Kemudian rule yang akan kita tambahkan ada 2, rule pertama[1] untuk ACCEPT/Mengizinkan dan rule kedua untuk DROP/Blokir. Rule tersebut adalah sebaagai berikut ini:


/interface bridge filter add action=accept chain=forward dst-port=67 ip-protocol=udp mac-protocol=ip out-interface=ether1 src-port=68 add action=drop chain=forward dst-port=67 ip-protocol=udp mac-protocol=ip src-port=68


Perhatikan hasil perintah di atas yang kita copykan kedalam terminal winbox mikrotik . parhatikan untuk rule accept harus di nomer paling kecil atau paling atas.

Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security
Pencegahan DHCP Rogue dengan Bridge Filter | DHCP Security
Terima kasih sudah berkunjung semoga bermanfaat , silakan berkomentar di kolom komentar dan share jika artikel ini bermanfaat .
Baca selengkapnya

DHCP Security Pada Jaringan Mikrotik

Hi everyone ! 😆 . Hallo mas bro dan mbak bro salam Love Mikrotik ya 😆😆😆

Melanjutkan tulisan sebelumnya dengan judul :

Cara Konfigurasi DHCP Server Pada Mikrotik Secara Mudah


pada prinsipnya DHCP sudah memudahan client kita untuk bisa terkoneksi dengan router kita sehingga tidak repot lagi untuk bisa internet/terkoneksi. DHCP selain memudahkan kita untuk tahap lanjutkan kita juga perlu melakukan konfigurasi DHCP Security pada jaringan kita, sebagai langkah preventif/pencegahan dan keamanan. 

DHCP Security yang akan kita lakukan pada artikel ini adalah langkah preventif/pencegahan terjadinya conflik ip yang di akibatkan oleh user/client kita melakukan konfigurasi ip secara manual di sini akan kita paksa agar user atau client melakukan konfigurasi secara otomasi mengukuti DHCP server. 

DHCP Security Pada Jaringan Mikrotik

DHCP Security: Add ARP fo Leases


agar user/client kita tidak melakukan konfigurasi ip secara manual yang bisa membuat ip conflict pada jaringan kita, kita bisa menggunakan DHCP Security: Add ARP fo Leases. dengan konfigurasi ini membuat user yang melakukan konfigurasi secara manual tidak bisa melakukan interkoneksi dengan jaringan router kita .

cara mengaktifkan opsi 'Add ARP for Leases'. Caranya cukup mudah dengan klik dua kali pada DHCP Server dan centang opsi tersebut yang terletak di bagian paling bawah .


Kemudian  pada interface router dimana terdapat DHCP Server kita rubah parameter 'ARP' menjadi opsi 'reply-only'. Hal ini bertujuan agar router tidak melakukan update secara otomatis di tabel ARP List saat ada client/user yang terkoneksi menggunakan IP Address secara Static/Manual.



Langkah ini tentu lebih membuat jaringan terhindar dari conflict ip address .

semoga bermanfaat , terimkasih telah berkunjung :)

Baca selengkapnya

Cara Konfigurasi DHCP Server Pada Mikrotik Secara Mudah

Hi everyone ! 😆 . Hallo mas bro dan mbak bro salam Love Mikrotik ya 😆 . 

para penggiat IT khususnya untuk Network pasti sudah paham arti dari DHCP,  

DHCP  atau "Dynamic Host Configuration Protocol" adalah protokol dengan basis arsitektur client/server yang di gunakan untuk memudahkan pengalokasian alamat IP dalam satu jaringan.

Cara Konfigurasi DHCP Server Pada Mikrotik
Cara Konfigurasi DHCP Server Pada Mikrotik Secara Mudah


Dengan adanya DHCP pada jaringan akan memudahkan untuk memberikan alamat IP kesetiap perangkat yang terhubung sehingga saat client akan melakukan koneksi ke sebuah jaringan tidak perlu lagi melakukan konfigurasi pemberian alamat IP secara manual karena IPnya sudah secara otomatis di berikan oleh perangkat server yang menggunakan DHCP .

Pada implementasinya DHCP sangat memudahkan kita, terlebih lagi saat kita memiliki jaringan yang memiliki client dengan perangkat mobile, kabayangkan kalau protokol DHCP tidak ada, pasti ribet harus tanya sama admin jaringan saat kita mau melakukan koneksi ke suatu jaringan. tanya sama adminnya eh IP nya berapa mungkin kalau satu orang yang tanya admin gak capek jawab , cobabayangin kalau yang nanya ada 100orang . wkkwkwkwkwk udah ah kita lanjut ke pembahasan sesuai judul di atas .

Cara Konfigurasi DHCP Server Pada Mikrotik Secara Mudah



1. Setting/Konfigurasi IP yang akan di gunakan untuk client .



ip address add address=192.168.20.1/24 interface=ether2-Lan

tentukan IP dan Interface yang akan di gunakan untuk DHCP server


2. Setting/Konfigurasi DHCP Server IP - DHCP server


step [1] Konfigurasi DHCP Server IP - DHCP server
step [1] Konfigurasi DHCP Server IP - DHCP server

Konfigurasi DHCP server 

ip - DHCP server [pada winbox tombo navigasi sebelah kiri winbox]


Konfigurasi DHCP Server IP - DHCP server
step [2] Konfigurasi DHCP Server IP - DHCP server 
tekan saja tombol next (mudahkan)

step [3] Konfigurasi DHCP Server IP - DHCP server
step [3] Konfigurasi DHCP Server IP - DHCP server
 tekan tombol next lagi 
step [4] Konfigurasi DHCP Server IP - DHCP server
step [4] Konfigurasi DHCP Server IP - DHCP server
tombol next di tekan lagi , range IP address yang akan di distribusikan ke client 

step [5] Konfigurasi DHCP Server IP - DHCP server
step [5] Konfigurasi DHCP Server IP - DHCP server 

setting ip DNS yang akan di distribusikan kepada client , dalam jaringan saya menggunakan opendns , hal ini bisa di sesuaikan dengan jaringan anda jika menggunakan jaringan dari speedy bisa menggunakan DNS speedy atau bisa juga menjadikan gateway sebagai DNS jika di konfigurasi DNS sudah anda konfigurasi .



step [6] Konfigurasi DHCP Server IP - DHCP server
step [6] Konfigurasi DHCP Server IP - DHCP server


lease time parameter untuk lamanya ip address di ingat untuk satu mac address

step [7] Konfigurasi DHCP Server IP - DHCP server
step [7] Konfigurasi DHCP Server IP - DHCP server
oke tinggal klik saja oke , ip DHCP server sudah berhasil anda konfigurasi .  Sekian Dari saya seorang BANGSAWAN  , semoga artikel ini bermanfaat . dan mambantu anda silakan share semoga bisa membantu orang lebih banyak dengan artikel saya ini . 
Baca selengkapnya

cara mudah blokir website menggunakan mikrotik firewall filter rules

I Love Mikrotik, Salam ngeblog mas bro mbak bro, semoga tulisan kali ini bisa membantu untuk yang mau ngeblokir website menggunakan mikrotik tapi bingung mau mulai dari mana .

jika mas bro ngetik pertanyaan di google dan di arahkan ke blog saya ini berarti tulisan ini bisa berguna untuk mas bro . oke kita lanjut ke judul yang saya tulis di atas .

Cara Mudah Blokir Website Menggunakan Mikrotik Firewall Filter Rules

Cara Mudah Blokir Website Menggunakan Mikrotik Firewall Filter Rules
Cara Mudah Blokir Website Menggunakan Mikrotik Firewall Filter Rules

dalam kasus ini saya mencontohkan blokir situs detik.com , kalau mas bro ada situs lain yang mau coba di blokir juga ya silakan :)


ok, sesuai judul kita coba memblokir trafik yang menuju ke suatu website menggunakan mikrotik memanfaatkan konfigurasi firewall/filter rules  .

perintah cli mikrotik nya cukup mudah seperti di bawah ini .



/ip firewall filter add chain=forward content=detik.com action=add-dst-to-address-list address-list=blokdetik
/ip firewall filter add chain=forward action=drop dst-address-list=blokdetik

cara settingnya cukup mudah mas bro tinggal copy pastekan cli mikrotik di atas ke terminal mikrotik menggunakan winbox . "content=detik.com"   bertujuan untuk menandai trafik yang mengandung content detik.com kemudian action nya menambahkan ke address list sebagai dst address list , kemudia script baris kedua melakukan drop menggunakan dst address list yang sudah di tambahkan dengan perintah di baris pertama .


untuk langkah konfigurasi blokir menggunakan winbox gambarnya di bawah ini ya :)

Step Pertama 
cara mudah blokir website menggunakan mikrotik firewall filter rules
cara mudah blokir website menggunakan mikrotik firewall filter rules | winbox

Step Kedua

cara mudah blokir website menggunakan mikrotik firewall filter rules | winbox
cara mudah blokir website menggunakan mikrotik firewall filter rules | winbox

semoga bermanfaat ya mas bro dan mbak bro , jika rasanya tulisan ini bermanfaat silakan di share ya . atau komentar, semakin banyak share dan komentar akan menambah semangat saya untuk memberikan tulisan yang lebih bermanfaat . terima kasih kunjunganya di  blog saya dengan judul "cara mudah blokir website menggunakan mikrotik firewall filter rules"
Baca selengkapnya

Iniloh Arti Product Code Yang Ada Pada RouterBoard Mikrotik

Hay mas bro atau mbak bro.. salam hangat nulislagi di blog soefyansyah.blogspot.com, blog dari seorang BANGSAWAN . Kesempatan kali ini ingin coret coret arti dari yang tertera pada product mikrotik .

Arti Product Code Yang Ada Pada RouterBoard Mikrotik
Iniloh Arti Product Code Yang Ada Pada RouterBoard Mikrotik

Iniloh Arti Product Code Yang Ada Pada RouterBoard Mikrotik



Mikrotik memudahkan kita pada pengguna product untuk mengenali speck dari product yang akan kita beli atau kita gunakan. Mungkin banyak yang cuek dengan kode merk atau product yang ada di sebuah Router Board Mikrotik

Sebuah Contoh 

  • Contoh Product Code Mikrotik 
  • RB750, 
  • RB751Ui-2HnD, 
  • RB951G-2HnD, 
  • RB912UAG - 2HPND, 
  • RB2011UiAS-IN, 
  • CCR1009-8G-1S-1S+, 
  • CRS226-24G-2S+RM, dll.

Penamaan pada RouterBoard Mikrotik sudah distandarkan oleh mikrotik , adapun format yang di gunakan sebagai berikut :

<board name> <board features><built-in wireless> <wireless card features><connector type><enclosure type>

atau dalam kasus lain

<nama board> <fitur board><wireless bawaan><fitur wireless card><tipe konektor><tipe wadah/casing

dari format parameter di atas dapat di simpulkan untuk product mikrotik dengan code atau tipe RB750 dan di simpulkan sebagai berikut .


Board Name (Nama Board)
  • RB750
  • RB = RouterBoard
  • 7 = Menunjukkan nama seri (700 series)
  • 5 = Menunjukkan jumlah interface kabel (ethernet, SFP, SFP+)
  • 0 = Menunjukkan jumlah interface wireless (mini PCI) 

Dapat di simpulkan untuk product mikrotik RB750 adalah sebuah Routerboard dengan series 700 yang memiliki 5 Interface Ethernet tanpa memiliki Interface wireless .


Fitur Board (Board Features)

Penulisan Fitur board dituliskan langsung setelah nama/code product board tanpa spasi atau tanda baca strip. Berikut ini Board Features yang ada pada product kode Mikrotik :


  • U - USB
  • P - daya injeksi power dilengkapi kontroler (PoE out)
  • i - single injector port power tanpa kontroler (single PoE out)
  • A - memiliki lebih banyak memori (dan level lisensi biasanya lebih tinggi)
  • H - Kekuatan CPU lebih tinggi
  • G - Gigabit (mungkin termasuk "U", "A", "H", jika tidak digunakan dengan "L")
  • L - versi ringan (Edisi light)
  • S - Port SFP
  • e - Ekstensi interface PCIe card
  • x <N> - di mana N adalah jumlah core CPU (x2, x16, x36 dll)
  • R - MiniPCI atau Slot MINIPCIe

Demikianlah sedikit penjelsan code product yang terdapat di RB (RouterBoard) mungkin bisa membantu mas bro dan mbak bro untuk lebih mengenali product mikrotik . tidak kenal maka tidak sayang "i love mikrotik"


Baca selengkapnya